TARGIT Custom SSIS Tasks package


The Custom SSIS Tasks package is downloaded from TARGIT's Download Center.


Try to download the correct version according to your SQL server version.


Note: Even if you should have a later SQL Server version, e.g., SQL 2022, you can still download and install the latest TARGIT Custom SSIS Tasks package. Just needs a little tweaking - see the Deployment Target Version section below.


Once downloaded, simply install the package from the .exe file. Make sure that you close Visual Studio (or Data Tools) during the installation.


When you reopen an SSIS package in Visual Studio (or Data Tools), you will now see the TARGIT Custom SSIS Tasks in the SSIS Toolbox:


Deployment Target Version

If the TARGIT Custom SSIS Tasks does not show in the SSIS Toolbox, it may be due to your SSIS project being of the wrong target version. E.g., if you install the 'TARGIT Custom SSIS Tasks for Microsoft SQL Server 2019' in a SQL Server 2022 environment.

To correct this, in the Solution Explorer in Visual Studio (or Data Tools), open properties for your Integration Services Project and change the TargetServerVersion property to the version that matches your TARGIT Custom SSIS Tasks package:


Setting the TargetServerVersion will not limit where e.g., a Period Table can be deployed. Even if the TargetServerVersion is set to SQL Server 2019, you can still use the custom tasks to produce tables in e.g., a SQL Server 2022 database.

Was this article helpful?
0 out of 0 found this helpful


  • Hi,

    I just installed the latest Visual Studio 2022 which now provides the SSIS Integration Extentions.
    Database Server is SQL Server 2022.

    After installing the SSIS Custom Tasks for SQL Server 2022, the custom Tasks are still not available. They are not only unvisible, the existig tasks throw an error.

    Are they compatible with Visual Studio 2022? Any other Ideas?

  • Hi Marc,

    Did you check the "TargetServerVersion" in the Integration Services Project properties? (As in the screenshot in the article.)

    BR / Ole

  • Hi Ole, yes I did twice. Reloaded the Project, Restartet Server, Repair Installation, Again Restart, Reload. 

    But still no success...

    BR / Marc

  • Hmm?

    I am working with Visual Studio 2019. What is your version?

    Also, have you tried creating a new SSIS project from scratch? Rather than trying to work with an existing one?

    BR / Ole

  • I'm working with Visual Studio 2022, since the SSIS and SSAS Extentions are now official available vom Microsoft.

    I think this is the reason, but what can we do now? 

  • Just for the record:

    I did some testing on a clean machine (Windows Server 2016).

    • Installed SQL 2022
    • (Installed SQL Management client. Latest = version 19.1)
    • Installed Visual Studio 2022
      • Added extension for Integration Services
      • (Added extension for Analysis Services)
    • Installed TARGIT Custom SSIS tasks 2022
    • Created a new SSIS project.
    • Verified that TARGIT Custom SSIS tasks (Enum, Period, Quality) is available in the SSIS toolbox.
  • Hi Ole,

    thanks a lot for your investigation. I just made some additional steps, installing the english language package, reinstalled the Tools, installed again. But no success.

    Here we have the situation, that the SQL Server, that you installed on the same machine is NOT running on the server, where VS is installed. Could this be the problem? 

  • OK, for Fun, I installed the 2019 Tools, set the Target SQL Server Version to 2019 and it works, both with english or german language settings. Then I removed the 2019 tools, installed 2022, set Server Version again to 2022 and: No Tools available. Any other ideas?

    Thanks in Advance.

  • Hi Marc

    I had the same Problem. Only way to fix it, was to move the dll installed by the targit msi installer to  C:\ProgramData\TARGIT\SSIS\TARGIT SSIS Custom Tasks\Tasks, Pipeline Components to the C:\Program Files (x86)\Microsoft SQL Server\160\DTS\Tasks, \PipelineComponents directory.

    (Make a Copy of the Files to one of your personal directory, uninstall the Targit Custom SSIS Tasks, then move to SQL Server folder.)

    Then do the installation by hand (move to .NET Global Assembly Cache). --> Open Visual Studio, Tools, Command Line, Developer Command Prompt --> Then for each DLL gacutil -i (for example 

    gacutil -i "C:\Program Files (x86)\Microsoft SQL Server\160\DTS\PipelineComponents\TARGIT.SSIS.CustomTasks.DataReaderNAVNative.dll"
    Microsoft (R) .NET Global Assembly Cache Utility.  Version 4.0.30319.0
    Copyright (c) Microsoft Corporation. Alle Rechte vorbehalten.

    Die Assembly wurde dem Cache erfolgreich hinzugefügt.

    Microsoft Visual Studio 2022, Community Edition 17.9.0 64bit


  • Hi Martin,

    thank you for your post. I will try this. Are you also running the Visual Studio and the SQL Server Installation on different Systems?

    On my Development System, I have no SQL Server Installation, only the Visual Studio and I am deploying SSIS vs a SQL Cluster Installation.


  • Hi Marc,

    yes. They are on 2 different Systems in the same Domain, i'm not working on the Server running Targit (Client System running Visual Studio, 1 virtual Server running Targit, 1 Database Server). The Targit installer puts the dll Files in the Targit install direction on the client System. This doesn't work in my enviroment. I have to put them into the SQL Server direction on the Client System (C:\Program Files (x86)\Microsoft SQL Server\160\DTS (you have to choose the direction depending on the target SQL Server Version 80/110/130/150 or 160). After putting them to the GAC it works fine for me.

    I still didn't deploy it, because we are changing SQL Server Versions later. Just preparing... please let me know, if there is also some action to do on the server when you deploy the ssis solution.

    BR Martin


Please sign in to leave a comment.