Format gets lost when exporting to Excel

I have data shown in crosstab as hh:mm:ss formatted via "format numbers". The value type is minutes as database default. When I export these data to excel, the format hh:mm:ss gets "lost" and data are shown in minutes rather then the desired fomat. 
Anyone an idea what is causing this? Measure format is setup correctly in Visual Studio.
Thank you!


  • Hello!

    Does it do the same thing when you export to CSV?

  • Hi Tyler,

    the issue remains also when exporting to CSV. The only time it's not changing format is when exporting a crosstab to PDF.


  • Try changing the settings of exporting - shows when you right-click.
    There is an option to remove og keep format


  • Hi Steffi,

    I am not sure anything can be done about it as it is now. TARGIT and Excel works in different ways when it comes to presenting numbers as time.

    In TARGIT you can take any number, e.g. a decimal number, and through purely number formatting, you can present this as time.

    In Excel however, to present a number as time, you will need to do a conversion - using the TIME() function - and potentially do one or more intermediate calculations before reaching an acceptable result.

    At least this is where it stands right now - however, the input has been noted, and I might pursue options to improve this in a future release.

    BR / Ole

  • Hi Ole,

    thank you for the explanation. It would be great, if this could be improved in the near future release, as it's causing some issues for our end users.



Please sign in to leave a comment.

Didn't find what you were looking for?

New post