Creating a global dimension ?


I am trying to create a global dimension on an organization hierarchy but it doesn’t seem to work.

As I haven’t worked with global dimensions before, I then contacted a colleague from my network (Næstved kommune) who have introduced global dimensions on social security number (cpr).

We have exactly the same cubes (from FLIS), so I expected to be able to copy their solution. But it still doesn’t work.

Anyone have an idea why?

I have created a XML-file named GlobalDimensions in the 'Settings' folder on our TARGIT Server:

In the XML-file I have written:

I’m not sure what the ‘standalone=”yes” ‘ part is for, but it is identical to the text when I open a normal analysis:

And I have opened an analysis with the two dimensions to check if the names are correct:

I have even got my IT colleague to restart the Targit server. (I don’t know if this I necessary when making changes to the GlobalDimension file?)

Or do I need to get IT to restart some of the other services too (e.g. with red marker) ?



  • Hi Louise

    Your XML-file seems correct and it's also placed in the correct folder.

    Restarting the TARGIT server is enough - it makes sure that the cache is cleared the latest version of your xml file is used.

    so what is wrong? There is at least one bug-fix in 2021 update2 - so if you are currently on an older version than this, that might be the reason? Maybe Næstved is on a newer build?

  • Ok, thanks for your answer.

    Yes, Næstved has upgraded to 2021 and we are still on 2019. (Though, I think they had the global dimension in function before upgrading).

    We desided to wait for your next update 4. Do you know when this will be released? (Or at least your fix to the DAX)? 

  • June 9th we are planning to release update 4

  • Is there any way to check whether the GlobalDimensions File was loaded correctly or whether there are any other issues with GlobalDimensions?

    I set up the file (GlobalDimensions.xml) in the right folder (\\targitserver\c$\ProgramData\TARGIT\ANTServer\Settings\GlobalDimensions) and checked the dimension and hierarchy names, even restarted the targit ANT Service, but it just does not work. I am using SSAS with multidimensional cubes and a dimension/hierarchy which is shared in SSAS accross two cubes - so I know the keys must be the same, also the hierarchies - just the dimension names are cube-specific.

    Is there a way for me to find out whether the GlobalDimensions.xml was loaded correctly and whether the TargitServer/Client was able to match the data from the file to a dimension in the report?



  • I forgot to mention we are using Targit 2021 Summer Update 1 (21.8.25001)


Please sign in to leave a comment.

Didn't find what you were looking for?

New post