Data Discovery after updating and it being an application pool


We have updated our Targit to update 4 without problems, from summer 2021. There have been no problems while updating our service or clients, however our Data Discovery cannot read excel files anymore.

I have set up the Service under application pools, currently as my self (since i loose our different cubes if i try to run it as an ApplicationPoolIdentity).

We currently get either "file could not be found" or "unable to establish connection". We are storing the files on a different server and have tried with them on the same server as targit but without luck.

Are there anyone who have had the same problems and have had luck with solving this ?

Best Regards,
Bo Jacobsen



  • Hi Bo,

    I have checked our Support system and found a couple of similar cases, albeit not on the update 4 version yet.

    However, the remedy seemed to be to uninstall Data Discovery (only Data Discovery) and then reinstall it from your update 4 installer.

    Let me know if this will work for you.

    BR / Ole

  • Hi Ole,

    Uninstalling and reinstalling Targit Discovery solved the problem, with files not found and unable to establish a connection, though we still need to use custom account.

    When using ApplicationPoolIdentity the data and cubes in our data discovery disappear and when we try to create a new source files as ApplicationPoolIdentity, we get the feedback saying "Current State Broken during start"

  • Hi Bo

    Great that you we're able to fix it.

    The custom account is needed as it is mentioned in the release notes:

    • If running Data Discovery with a service account that has specific access to files and folders, please note that with 2022 Spring, Data Discovery runs under the IIS, hence the application pool running it, must run with the same service account to be able to access the same files and folders.


  • Hi Niels,

    Thanks for the information.



Please sign in to leave a comment.

Didn't find what you were looking for?

New post