Select default identity provider for Anywhere login

When you work with setting up identity providers using the open id connect integration in TARGIT, your users will be met with several options to login to TARGIT.

They will see your Open-ID configured login as an option and also the built-in TARGIT login prompt will appear.

With the TARGIT 2021 Summer Release, you can set up a default identity provider, which will make sure that the users only see the relevant login prompt.

Was this article helpful?
0 out of 0 found this helpful

Comments

7 comments
  • Hi Ole 
    What are the settings in the targitsettings.json you have to set to get it working, i can see that is noted in the release note but not how to do it 

    regards Claus Donner

    0
  • Hi Claus,

    There is a knowledge base article here: https://community.targit.com/hc/en-us/articles/360016170937-OpenID-user-authentication. Let me know if it is helpful or not.

    BR / Ole

     

    0
  • Hi Ole, The article describes how to set it up, and that we have up and running against several customers both against AD and azure logins with no problems. But one of the thing our customer has reported back is exactly option to remove the other options to log in.

    But  as you describe in the article, there now is an option to set a defalut provider ,and the changelog on the release saids it is in the targitsettings.json file.
    So we need the setting in the targitsettings.json what should we write and how is it formatted.

    In the change log https://portal.targit.com/Download-Support/Download-center?release=1029&page=changelog the first point under Anywhere states that:
    "Enable default selection of Identity Provider (OpenID)
    The option for Anywhere is now available in Targitsettings.json"

    But i have found nowhere how to set/enable it 

    Regards Claus

    0
  • Hi Claus,

    A standard targitsettings.json look like this:

    {
    "TargitSettings": {
    "Server": "localhost",
    "UseCdn": false
    },
    "SessionSettings": {
    "SessionTimeout": 60,
    "IdleTimeout": 0,
    "Mode": "Internal"
    }
    }

    You need to add "IdentityProvider" like this:

    {
    "TargitSettings": {
    "Server": "localhost",
    "UseCdn": false,
    "IdentityProvider": "EasyAccess"
    },
    "SessionSettings": {
    "SessionTimeout": 60,
    "IdleTimeout": 0,
    "Mode": "Internal"
    }
    }

    "EasyAccess" is the ID, you specified in TARGIT Management, when you configured the Identity Provider:

    Best regards,

    Jesper da Silva Endelt

    0
  • Hej Jesper

     

    Just tried, and it works like a charm, thanks :-)

    Just a side note the standard json looks like 

    {
    "TargitSettings": {
    "Server": "localhost",
    "UseCdn": false
    },
    "SessionSettings": {
    "SessionTimeout": 60,
    "IdleTimeout": 0,
    "Mode": "Internal"
    }
    }

    i think you copied the same twice

    Claus

    0
  • Hi Claus,

    Glad to know it works - and thank you for the hint on my double copy/paste.... I've updated the original post :-)

    Jesper

    0
  • Hi Jesper,

    Do you know why validation and loading Targit Anywhere page take about these 10-15 sec. It does the same when we test the script from Targit Managment. I also noticed that from your earlier webinar  "openid-utilize-the-power-of-user-authentication" where the result values from AAD and run the script to lookup permissons from AD.

     

    0

Please sign in to leave a comment.