TARGIT Compatibility - .NET versions

TARGIT is constantly modernizing its platform and components by using the latest tools and drivers for software development.

This article will give you an overview of the .NET versions used for the individual components of the TARGIT Decision Suite.

For instance, you may use the table to determine if the current version of your TARGIT installation requires any of your third party drivers (dlls), used for providing access to a third party system, is of the correct .NET version. The driver should be of the same .NET version as the TARGIT component using it.

Component 2021 Update 3 2022 Winter Update 2 2023 August 2024 May (24.05.03003)
Data Service .Net Framework 4.5.1 .NET 6 .NET 7 .NET 8
Scheduler Service .NET Framework 4.5.2 .NET Framework 4.7.2 .NET 7 .NET 8
tiImport.exe .NET Framework 4.0 .NET 6 .NET 7 .NET 8
ETL Studio .NET Framework 4.5.2 .NET Framework 4.6.1 .NET 7 .NET 8
Data Drivers .NET Framework 4.6.1 .NET Standard 2.0 .NET 7 .NET 8
TARGITDB .NET Framework 4.0 .NET 6 .NET 7 .NET 8
TARGIT Client .NET Framework 4.7.2 .NET 6 .NET 7 .NET 8
Was this article helpful?
1 out of 1 found this helpful

Comments

0 comments

Please sign in to leave a comment.